Propriétés de l’axe
"Propriétés de l’axe” s’ouvre en sélectionnant l’icône "Grille" dans le ruban "Modélisation". Vous pouvez aussi choisir l’option "Propriétés" du menu contextuel (affiché par un clic droit de la souris) après la sélection d’un axe existant.
Pour définir un nouvel axe, renseignez les champs du formulaire. Indiquez ensuite les extrémités de la ligne d’axe dans la zone de dessin.

Le formulaire "Propriétés de l’axe” comprend les champs suivants :

-
Segment unique
permet de créer un axe rectiligne. Cliquez sur le point de départ, puis sur le point d’arrivée. 
- Axe multi-segments
permet de créer un axe unique composé de plusieurs segments de forme quelconque.
(Clic gauche pour commencer la création, touche "Esc" pour revenir en arrière, clic droit pour terminer la création.)
- Axe courbe
se crée en spécifiant le rayon.
Définition d’un nouvel axe
Suivez ces étapes pour créer un nouvel axe :
- Cliquez sur l’icône "Grille" du ruban "Modélisation" pour ouvrir “Propriétés de l’axe”.
- Modifiez les données dans les champs du formulaire “Propriétés”.
- Vous pouvez définir le "Libellé de l’axe" ou la "Méthode d’insertion".
- "Code de direction" n’a plus besoin d’être modifié manuellement. La direction est détectée automatiquement lors du tracé de l’axe.
- Cliquez avec le bouton gauche de la souris sur le premier point, puis sur le second point, et relâchez le bouton. Le nouvel axe apparaît.
- " Longueur " et " Angle " permettent de contrôler la direction et la longueur de la grille tracée pendant l’insertion.
- Pour activer ces options et limiter le déplacement du curseur aux directions horizontale ou verticale (ou selon l’angle défini), maintenez la touche Ctrl enfoncée pendant le déplacement vers le second point. Relâchez-la après le bouton gauche de la souris.
- Vous pouvez aussi générer des axes parallèles à partir d’un axe existant.
- Pour cela, sélectionnez d’abord un axe existant, puis faites un clic droit pour ouvrir le menu contextuel.
- Choisissez ensuite l’option " Décaler l’axe " pour activer le formulaire de génération.
- Si le formulaire " Propriétés de l’axe " est actif pendant la sélection d’un axe, vous pouvez aussi activer le formulaire de génération en choisissant " Décaler l’axe " dans la barre d’outils " Modifier ".
- Lorsque le formulaire correspondant s’affiche, saisissez une valeur dans le champ « Décalage par rapport au précédent » pour indiquer la distance de décalage par rapport à l’axe existant.
- Le nouvel axe est placé au décalage indiqué par rapport à l’axe précédent, du côté choisi.
- Pour définir un autre libellé, modifiez le champ « Axe » avant de cliquer sur le côté du décalage.
- Pendant le tracé, la longueur (L) et l’angle local s’affichent. Les distances relatives ∆x & ∆y par rapport au SCU local apparaissent aussi.
- Appuyez sur F2 pour saisir la longueur (L) de l’axe via le système de saisie dynamique (DIS)
- Appuyez sur TAB pour passer à la saisie de l’angle

- Si vous saisissez une valeur dans la zone de texte, le paramètre associé est verrouillé. Appuyez sur ESC ou sur l’icône de cadenas à droite de la zone pour le déverrouiller.
- Dans l’une ou l’autre zone de texte, vous pouvez utiliser la notation abrégée Length<Angle ou DeltaX, DeltaY (sans passer par TAB.)

Définition d’un axe courbe
La méthode de définition des axes courbes est la suivante :
- Cliquez sur l’icône « Grille » du ruban « Modélisation » pour ouvrir le formulaire « Propriétés de l’axe ». Saisissez le nom de l’axe dans le champ « Libellé ».
- Choisissez « Insertion d’axe courbe » comme méthode d’insertion, puis cliquez pour définir le point de départ et le point d’arrivée :
- Le premier et le deuxième point définis ainsi sont respectivement les points « I » et « J » de l’axe.
- Déplacez le curseur pour définir le décalage de la courbe, puis cliquez pour confirmer.
- Vous pouvez aussi appuyer sur « F2 » pour définir le décalage de la corde de l’axe. Les valeurs négatives sont acceptées dans la boîte de dialogue.
- Après avoir modifié les champs de cette boîte de dialogue, appuyez sur « ENTER » pour terminer la définition de l’axe courbe.
- L’axe est alors tracé à l’écran.
Générateur d’axes orthogonaux


Insertion de grille
Comprend les champs « Point de référence » et « Angle d’insertion ». Les coordonnées X et Y du point de référence sélectionné précédemment sont renseignées automatiquement dans les champs Point de référence. Vous pouvez modifier ces valeurs pour définir un nouveau point de référence.
L’angle d’insertion est l’angle de rotation des axes générés dans les deux directions (« 1 » et « 2 »). Il se mesure dans le sens antihoraire, par rapport aux directions par défaut.
Axes de direction 1 / Axes de direction 2
Comprend les champs « Étiquette d’axe », « Pas », « Espacement(s) des axes » et « Longueur de prolongement des axes ». Renseignez-les pour générer les axes de direction 1 et de direction 2.
| Fonction |
Description
|
|
Étiquette d’axe
|
Étiquette du premier axe dans cette direction.
Les étiquettes des axes de direction 1 (horizontaux) commencent du bas vers le haut.
Les étiquettes des axes de direction 2 (verticaux) commencent de la gauche vers la droite.
|
|
Espacement(s) des axes
|
Espacement entre chaque axe d’une même direction. Séparez les valeurs par une virgule si les espacements sont inégaux. Vous pouvez saisir des espacements répétés avec le multiplicateur " * ". L’espacement s’écrit avant le nombre de travées. (Ex. 5000, 2000*3, 4000)
|
|
Pas
|
Incrément de l’étiquette d’axe utilisé pour générer les étiquettes successives. |
|
Longueur de prolongement des axes
|
Distance de prolongement des axes au-delà des intersections.
|
Menu contextuel des axes & onglet Options d’axe
- Onglet du ruban "Options d’axe"

- Menu contextuel (affiché par un clic droit de la souris)

- Les fonctions « Déplacer » et « Étirer l’axe » agissent sur plusieurs axes sélectionnés.
- Les fonctions « Pivoter l’axe », « Décaler l’axe » et « Modifier l’extrémité de l’axe » exigent la sélection d’un seul axe.

Déplacer un axe
- Sélectionnez un ou plusieurs axes.
- Cliquez sur "Déplacer l’axe" dans le menu contextuel de l’axe ou dans l’onglet Options d’axe.
- Déplacez le curseur de la souris. L’aperçu de l’axe s’affiche.
- Appuyez sur « F2 » pour saisir une valeur manuellement :
- Saisissez la distance parallèle du déplacement.
- Vous pouvez aussi saisir les valeurs [delta x] , [delta y] .
- Appuyez sur "Enter". L’axe est déplacé.
Étirer un axe
- Sélectionnez un axe ou un réseau parallèle d’axes. Choisissez l’option "Étirer l’axe" dans le menu contextuel de l’axe ou dans l’onglet du ruban.
- Cliquez avec le bouton gauche près de l’extrémité à étirer. Une règle indique la distance quand vous éloignez le curseur du premier point.
- Déplacez le curseur et cliquez à nouveau pour terminer l’étirement. Vous pouvez aussi utiliser "F2" pour saisir la distance, puis appuyer sur "Enter".
- La fonction d’étirement ne modifie pas la direction des lignes d’axe. Les lignes d’axe sélectionnées sont étirées de la longueur absolue de la ligne de glissement dans le plan XY.

Modifier l’extrémité d’un axe
- Sélectionnez un axe. Cliquez sur l’option "Modifier l’extrémité d’axe".
- Définissez la nouvelle extrémité de l’axe en choisissant un point.
- L’extrémité la plus proche de l’axe sélectionné prend la position du point choisi.
Étirer l’axe jusqu’aux intersections des éléments
- Sélectionnez un ou plusieurs axes, puis choisissez l’option « Étirer l’axe jusqu’aux insertions d’éléments ». La fonction s’applique alors aux axes sélectionnés (ou à plusieurs axes) du modèle.
- La boîte de dialogue « Étirer les axes jusqu’aux insertions d’éléments » s’ouvre.
- Les axes s’étirent automatiquement selon les paramètres dès que vous cliquez sur le bouton « OK ».
Options disponibles dans cette boîte de dialogue :

- Prendre aussi en compte les intersections d’axes
Si la grille d’axes est orthogonale, cochez cette option pour prendre en compte non seulement les points d’insertion des éléments, mais aussi les intersections d’axes.
- Raccourcir uniquement
Si vous cochez cette option, les axes sont seulement raccourcis pendant cette opération.
- Longueur de prolongement des axes
Les axes sont prolongés au-delà de l’insertion d’élément la plus éloignée (ou de l’intersection d’axes, si « Prendre aussi en compte les intersections d’axes » est cochée) de la valeur saisie dans ce champ.
- Appliquer aux axes sélectionnés ou à tous les axes
Par défaut, la fonction s’applique uniquement aux axes sélectionnés si elle est lancée depuis le menu contextuel. Si vous cochez l’option « Appliquer à tous les axes », l’opération s’applique à tous les axes du modèle.
Étirer un axe jusqu’à une limite
- Sélectionnez un ou plusieurs axes. Cliquez sur l’option « Étirer l’axe jusqu’à une limite ».
- Définissez la limite en désignant deux points pour étirer les axes sélectionnés.
- Les extrémités les plus proches des axes sélectionnés sont prolongées ou raccourcies jusqu’à la limite.
- Le processus est annulé si la limite définie n’est pas valide.
Faire pivoter un axe
- Sélectionnez un seul axe (l’option ne fonctionne pas avec plusieurs axes).
- Cliquez sur l’option « Faire pivoter l’axe ».
- Cliquez sur le point de base de la rotation dans la zone de dessin.
- Vous pouvez désigner le point de base de la rotation avec l’un des modes d’accrochage aux objets.
- Pour choisir l’intersection de deux axes comme point de base, cliquez sur le bouton "Intersection" du formulaire d’accrochage, placez le carré du curseur près de l’intersection voulue, puis cliquez avec le bouton gauche de la souris.
- Appuyez sur « F2 » pour saisir le nouvel angle de l’axe (mesuré dans le sens antihoraire à partir de l’horizontale) dans le champ "Angle", puis appuyez sur « Entrée ».
- Appuyez de nouveau sur "Entrée" : l’axe pivote.
Créer une vue de portique
Tableau des axes
Modifier la visibilité de plusieurs grilles

Recommandations pour la création des grilles / axes
- Évitez les axes très proches les uns des autres
L’insertion des éléments repose sur l’intersection des axes. Des axes trop nombreux et trop rapprochés risquent de faire choisir la mauvaise intersection lors de la création des éléments. - Utilisez le moins d’axes possible
Pour la même raison, modélisez uniquement les axes nécessaires. Seul le comportement structurel compte. De petits décalages architecturaux ont donc un effet négligeable. Il serait déraisonnable de modéliser deux axes parallèles distants de 30 mm seulement, alors qu’un axe unique suffit.
- Gardez des axes courts, limités à leur zone d’utilisation
Cette consigne limite aussi le nombre d’intersections d’axes. Vous raccourcissez automatiquement les axes en les sélectionnant, puis en faisant un clic droit > « Étirer l’axe jusqu’à l’insertion de l’élément ». - Définissez les axes en mode fantôme pour alléger l’affichage
Pour définir un axe en mode fantôme, décochez « Visible à l’étage courant » dans les propriétés de l’axe. Ces axes s’affichent alors en gris clair. Désactivez « Axes fantômes » dans l’onglet Calques (ruban Affichage) pour les masquer complètement.
- Effectuez la « Vérification du modèle du bâtiment » de façon progressive
La vérification du modèle du bâtiment détecte les erreurs courantes sur les axes. Pour plus d’informations, consultez l’article suivant : Vérification du modèle du bâtiment